Junos versions supported by OneConfig

Juniper SRX Series Gateways

For SRX / vSRX devices the following Junos versions are supported with OneConfig's system:

  • 12.1X44, 12.1X45, 12.1X46, 12.1X47
  • 12.3X48
  • 15.1X49

Platforms tested: SRX100, SRX110, SRX210, SRX220, SRX240, SRX300, SRX320, SRX340, SRX345, SRX550, SRX650, SRX1400, SRX3000, SRX5800, vSRX

Not supported:

  • vSRX 15.1X49-D15 or D40: you should use 15.1X49-D20 or higher. 15.1X49-D80 is preferred.

Juniper EX / QFX Switches

For EX devices the follow Junos versions are supported with OneConfig's system:

  • 10.*
  • 11.*
  • 12.*
  • 13.*
  • 14.*
  • 15.*

Not supported:

  • EX6000/EX8200/EX9200/QFX5100

 

Juniper NFX

For NFX devices, 15.1X53-D45.3 or higher is required. Please note that there is an issue with D45 - see workaround here